discorddownloader

A bash script that will download, extract, and create symbolic links for all versions of Discord on any distro. It can also be used to update all versions of Discord just by going through the installation process again. This script can also install BetterDiscord and mydiscord. If you run into any problems, join the discorddownloader Discord Server and ask for help in #dd-help.


Project maintained by simoniz0r Hosted on GitHub Pages — Theme by mattgraham, customized by simoniz0r and pazuzu156


View Source

Download Installer

Usage

Changelog

Credits


Usage

'dialog' is used to create a GUI for discorddownloader; the script will run in regular text mode without 'dialog'. Install 'dialog' to check out the new GUI!

Check out discord-install for a simplified version of discorddownloader that only manages Discord.

discorddownloader requires 'wget'. There may be other dependencies based on which options you choose to install.

Run discordownloader.sh and select one of the installation options.

Some of the commands involved in the install process will require root access.

You do not need to run this script as root; you will be asked to input your password when root access is needed.

Note: This script can only maintain one install directory of each Discord version. You will be prompted to remove your previous install if you try to install the same version of Discord twice.

  1. Choose a version of Discord to install.

  2. Install mydiscord (requires python3.x, python3-pip).

  3. Install BetterDiscord to existing Discord install directory (requires npm, nodejs).

  4. Uninstall: choose the version of Discord to uninstall.

  5. Exit script without installing.

discorddownloader can also install mydiscord and BetterDiscord

  1. mydiscord (requires python3.x, python3-pip)

    • mydiscord is a fork of beautifuldiscord that can hot-load CSS and JavaScript.
    • To use mydiscord, just run it while Discord is already running.
    • mydiscord requires psutil; the script will take care of installing it for you. If you have an older version of psutil on your system, you should remove it before running this script or update it yourself using python3-pip
  2. BetterDiscord (requires npm, nodejs)

    • BetterDiscord install uses tape.sh to allow installation to any directory and with multiple Discord installs.
    • BetterDiscord does not fully support Linux and may break at any time.
    • If you install BetterDiscord, I recommend grabbing the Even Better Repo plugin. It allows you to install plugins and themes through the Discord Settings menu.